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1 Basics & Beyond.. 

1.1 Introduction 
Microsoft Excel is a spreadsheet program that is designed to record and analyze numbers 
and data. Excel is very widely used for accounting and financial purposes. 
 
The files created in Excel are known as workbooks. In turn, each workbook can contain 
one or more worksheets. An Excel worksheet is laid out like a grid with horizontal rows 
and vertical columns. Columns are labeled with alphabets (A, B, C, etc.) while rows are 
given numbers (1, 2, 3, etc.). The intersection of a row and a column is called a cell. A 
cell is referred by a combination of column alphabet and row number (A1, A2, etc.). A 
cell is a primary unit of measure in Excel and all the information is stored in cells. . A 
range is a collection of contiguous cells (which form a rectangular block) on which the 
user wants to perform similar type of calculations. A range is referred to by a 
combination of the cell addresses of the diagonally opposite cells separated by a colon 
(A1:D6) 
 

1.2 The EXCEL Screen 
On loading MS-EXCEL (either through the shortcut menu, or icon on desktop or through 
the Start Menu), the following screen appears: 

 



 
The various components of the EXCEL Screen are explained in brief below: 

Sr. Contains Remarks 
1 Title Bar Contains the name of the File currently open and also has 

the window control buttons to either close or minimize the 
program0 

2 Menu Bar Contains the list of various commands that can be 
performed in MS-EXCEL. It can be invoked either by a 
mouse click or the Alt Key from the keyboard 

3 Tool Bars Contain buttons for some commonly performed tasks. The 
commands can be activated by a mere mouse-click 

4 Formula Bar Displays the content of the active cell. The left hand side of 
this bar includes the name box which contains the list of all 
the range names and thereby facilitates quicker worksheet 
navigation 

5 Column Labels Contains the headings of the columns. Can be used for 
column-wide operations like increasing column width, 
hiding columns, formatting entire columns, etc. 

6 Row Labels Contains the headings of the rows. Can be used for row-
wide operations like increasing row height, hiding rows, 
formatting entire rows, etc. 

7 Sheet Area The place where the actual data is entered. The Active Cell 
is surrounded by a dark rectangle. 

8 Sheet Tab Gives reference to the sheet which is currently active. One 
can quickly navigate through different sheets from here 

9 Additional Tool 
Bars 

Some additional toolbars 

10 Status Bar Includes the various information sent by EXCEL. Of 
particular use is the QuickSum Feature in the status bar 
which automatically displays the totals of the selected cells 

11 Scroll Bars & 
Split Indicator 

The Scroll Bars can be used for quick movement within a 
worksheet. The extreme top of the vertical scroll bar and 
the extreme right of the horizontal scroll bar contain a split 
indicator which permits the user to divide the sheet into 
two parts. 

12 Application 
Control Buttons 

These buttons are used to minimize or control the size of a 
particular file. 

 
The cell A1 is surrounded with dark rectangular block. It is the active cell. Any entry of 
data is made into the active cell.  

1.3 Moving Around 
A worksheet can contain upto 65,536 rows and 256 columns whereas the visibility of the 
information on the screen is restricted to the size of the screen (generally 18-20 rows and 
8-10 columns are visible at a time). Therefore, one may need to move around different 



sections of a worksheet. There are various ways in which one can move around very 
efficiently. 

1.3.1 Keyboard Shortcuts 
The most widely used option is of course a wheel-mouse but at times, the keyboard is 
very handy. For example, to reach the last entered cell in a worksheet one just uses the 
<Ctrl>+<End> combination. Similarly, <Ctrl>+<Home> takes one to the first cell of the 
worksheet (which is always A1). Using <Home> takes one to the first cell of the 
particular row. <End> can be used with the combination of the arrow keys to reach at the 
end of the list in the particular direction. A complete list of keyboard shortcuts is 
provided in Annexure “A” 

1.3.2 Range Names 
Sometimes it is convenient to use a descriptive name to name a cell or a range of cells.  
Named ranges can also be used in formulas and functions.  To name a range: 

1. Select the range to be named. 
2. Click the Name box on the left side of the formula bar 
3. Type the range name (up to 255 characters).  Valid names cannot use spaces 

and the first character must not be a number.  Also, the name cannot look like 
a cell address such as B14. 

4. Press Enter. 
OR 
1. Select the range 
2. Select Insert/Name 
3. Choose Define 
4. Type the name of the range. 
 
Once a particular range has been named, reaching that particular cell is very easy. Just 
choose the range name from the Name Box and you are taken there. 

 

1.3.3 Window Split & Freeze 
Many a times, one wants to refer to two different sections of a worksheet. For example, 
in case of a long list, the headings might scroll up. In that event, one can consider to split 
the window into two parts. One can split the windows by dragging the split handle which 
appears at the extreme top of the vertical scroll bar and the extreme right of the horizontal 
scroll bar. In the alternative, one can position the cell pointer to the cell where one desires 
a split and choose the command Split from the Window Menu. To remove the split, either 
re-drag the split bar or choose Window->Unsplit. 
 
While the movement of the split windows is synchronized, none of them is fixed. 
Therefore, it is possible to loose track of the titles if the mouse movements are not 
properly handled. To avoid such a situation, one can choose Window->Freeze Panes. 
To reverse the process, choose Window->Unfreeze Panes. 
 



1.3.4 Multiple Windows 
Windows Split does not permit asynchronous viewing. For such a purpose, one can 
consider opening multiple windows of the same file. To do this, choose Window-> New 
Window. Re-size both the windows using the mouse pointer. Of course, multiple 
windows of the same file are at times confusing to handle. 



2 Data Entry 
Information entered into a cell is understood either as a text entry, a value or a formula. 
Functions are also treated equivalent to formulae. Dates, time and percentages are stored 
as numbers (values). It is important that a particular information is stored in the correct 
format.  

2.1 Text 
Text entries or labels can contain any combination of letters, numbers and spaces. A label 
which is too long for the width of a cell floats across the cells to its right / left / both 
(depending on the alignment of the cell) as long as those cells do not contain any 
information. If the cells aren’t empty, the label is truncated or cut-off. By default, labels 
are left-justified. 
 

2.2 Number (including date, time, percent) 
Numbers and text are treated differently. The default alignment for text is left whereas for 
numbers, it is right. Secondly, if a value is too large to fit in the current cell width, Excel 
displays a series of # characters as a error signal. A list of various error signals and what 
they denote is enclosed as Annexure “C”. Values are displayed in the General Number 
Format. This display can be customized using the Format Cells command. 
 

2.3 Formulae 
 
A cell can also derive the value though a formula. The building of a formula is intuitive 
and can be easily mastered through practice. For example, if Cell A1 contains 3000 being 
the tax payable and you want to calculate the surcharge, go to Cell A2 and type the 
formula +A1*5% (as the surcharge rate is 5%) and Excel does the calculation for you. To 
get the gross tax liability, go to Cell A3 and say +A1+A2 (as gross tax includes tax and 
surcharge). The formula can also be built by pointing to the dependent cells instead of 
typing the cell address.  Excel evaluates a formula in a particular order of precedence. 
The operators used in a formula and precedence accorded by EXCEL are as under: 

Operator Description Precedence 
: Range of Cells 1 
, Union of Cells 2 
% Percentage 3 
^ Exponentiation 4 
* Multiplication 5 
/ Division 6 
+ Addition 7 
- Subtraction 8 
& Concatenation 9 
= < > Comparison Operators 10 

 



If the order of evaluation is to be changed, parenthesis should be used to group 
expressions within a formula. If more than one pair of parenthesis is present in a formula, 
Excel evaluates the expression in the innermost parenthesis first. 

2.4 Functions 
A cell can also derive its value through functions. Functions are processes, which have 
been defined and standardized by Excel. A complete list of functions can be found at 
Insert -> Function. A list of commonly used functions is enclosed as “Annexure B”. Few 
more common functions include the SUM function (which totals all the numbers in a 
particular range – of course, EXCEL also has the QuickSum Feature which displays the 
sum of the selected range in the bottom pane) and the IF function used to manage 
alternate calculations in varying situations (it is very simple to use and can be nested, but 
take care to use the brackets appropriately otherwise the results can be disastrous!). A 
very common example of the use of IF function is to calculate the tax payable by an 
individual. For example, if cell B3 contains the net taxable income of an individual, the 
tax payable by him (excluding surcharge) can be calculated using a nested IF function as 
stated: =IF(B3>150000,(+B3-150000)*0.3+19000,IF(B3>60000,(B3-60000)*0.2+1000, 
IF(B3>50000,(B3-50000)*0.1,0))) 

2.4.1 Using the Function Builder 
A function takes in certain standard arguments, undertakes the evaluation process and 
returns a particular result. In case one is unaware of the arguments, one can type the 
function name along with the opening parenthesis and click on the = sign on the Formula 
Bar. The Function Wizard presents the list of arguments and the brief description of the 
arguments. In such a fashion, one can build a formula through a Wizard and 
simultaneously learn the function itself. For example, the Function Builder Dialog Box in 
the case of PMT function is shown below: 

 

2.5 AutoComplete 
Manual data entry into a range of cells can be made faster with the assistance of 
AutoComplete - a feature which suggests the current cell entry based on the existing list. 
It should however be noted that AutoComplete has certain limitations – it does not work 



if there is a blank cell in the list, it works only when a unique combination consisting of 
at least one alphabet is met in the list. In case of multiple similar entries, a better option is 
the Pick from List which appears in the right-click shortcut of the mouse. 

2.6 AutoCorrect 
The AutoCorrect feature automatically corrects common typing errors as you type. For 
this purpose, Excel uses a database of commonly misspelled words. This database can be 
customized from the Tools -> AutoCorrect Menu. The following screen comes up: 

 
 
One can use the AutoCorrect feature to quickly type some normal text which is regularly 
used in an organization. For example, the organization name can be made a subject 
matter of AutoCorrect to speeden up data entry. 

2.7 AutoFill 
AutoFill is an in-built feature whereby one can fill up a particular range of cells based on 
some pre-determined series. For example, if one cell contains January and the next one 
contains February, one can just use the fill handle to automatically complete the entire 
range with the month names. One can create custom lists pertaining to one’s organization 
(for example, plant locations) from Tools -> Options -> Custom Lists. The following 
screen appears where one can either type in the required items or pick from a range of 
cells 
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