
Alias|Wavefront / Assistant Online / Maya / How Tos

How-to's are step-by-step tutorials that are designed to help you
learn more about Maya. While some lessons let you start from
scratch, other lessons may provide a start file for you to begin with.

Note - These files may not perform as expected. Always back up
your work before using any files downloaded from this website.

These how-to's have been updated to work in Maya 2.5. However,
unless otherwise noted, they will also work in Maya 2.0.

Maya how-to's are available in the following categories:

  Animation
How to Model a Flexo Maya 2.5 Complete

How to Build and Animate an Iris Maya 2.5 Complete

How to Pick Up an Object Maya 2.5 Complete

How to Animate an Accurate Clock      Maya 2.5 Complete

How to Animate an Extrusion Maya 2.5 Complete

How to Animate the Aiming of a Spotlight Maya 2.5 Complete

How to Animate a Rolling Cube Maya 2.5 Complete

How to Animate with Flow (Object) Maya 2.5 Complete

How to Animate with Flow (Curve) Maya 2.5 Complete

  Character
How to Create SoftBodies in Character
Animation 

Maya 1.5 FX

How to Blend Facial Poses Maya 2.5 Complete

  Compositing
How to Composite Hardware and Software
Rendered Images  NEW!

Maya Fusion Lite

How to Composite using zDepth Maps Composer 5.0

How to change the default event colors Composer 5.0

How to create a Composer undo Composer 5.0

How to Extract Images from a Movie Maya Fusion Lite

How to fake 3D shadows Composer 5.0

How to Glow Highlights Composer 5.0

How to layer an unpre-multiplied image      Composer 5.0

How to Manage your macros Composer 5.0

How to set up Maya renders for Compositing Composer 5.0

  Dynamics - Particle
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How to Create a Ring of Fire       Maya 2.5 Complete

How to use Particles to Drive Rigid Bodies Maya 2.5 Complete

How to Create an Exploding Fireball Maya 2.5 Complete

   Dynamics - Rigid Body
How to Animate a Chain Link Maya 2.5 Complete

How to Create a Newton's Pendulum Maya 2.5 Complete

  Dynamics - Soft Body
How to Animate a Melting Object     Maya 2.5 Complete

How to Create an Inflating Balloon    Maya 2.5 Complete

How to animate a Gelatin cube Maya 2.5 Complete

How to Create a Waving Flag Maya 2.5 Complete

How to Create Footprints Maya 2.5 Complete

  Games - NEW!
How to Prelight a Scene Maya 2.5 Builder

  Maya Fur
How to Comb Fur Maya 2.5 Unlimited

  MEL
How to use attrCollection.mel Script Maya 2.5 Unlimited

How to use an "relocateTexturesWin" Maya 2 Complete

How to use an Assistant Online MEL
Script   

Maya 2.5 Complete

Hot to use QTVR.mel Script Maya 2.5 Complete

  Miscellaneous
Learning Maya 2.5 Addendum (PDF 128k) Maya 2.5 Complete

  Modeling
How to Build a Spiral Staircase      Maya 2.5 Complete

How to Build a Polygonal Gear Maya 2.5 Complete

How to Use bevelCaps.mel Script  Maya 2.5 Complete

How to Use NURBS Booleans Maya 2.5 Unlimited

How to Create Square Surfaces Maya 2.5 Unlimited

  Paint Effects - NEW!
How to Create a Tree using PaintFX NEW! Maya 2.5 Complete

  Rendering
How to Make Natural Clouds Maya 2.5 Complete

How to Animate Texture Files   Maya 2.5 Complete

How to Create a Ball Env Reflection Map Maya 2.5 Complete

How to Create Camera Cuts Maya 2.5 Complete

How to Create a Double-sided shader      Maya 2.5 Complete

How to Create a Ghost Shader Maya 2.5 Complete

How to Create a Light GOBO with Barn Doors Maya 2.5 Complete

How to Create a Realistic Sky with EnvSky Maya 2.5 Complete

How to Create Realistic Shadows with EnvSky Maya 2.5 Complete

How to Create Realistic Glass      Maya 2.5 Complete

How to Create a Soft Spotlight Maya 2.5 Complete

How to Combine Bump and Displacement
Maps

Maya 2.5 Complete

How to Make a Cartoon Shader      Maya 2.5 Complete
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How to Make Water Ripple Maya 2.5 Complete

Technical Overview on Aliasing
Artifacts      

Maya 1.5 Base

Technical Overview of Maya Software
Rendering

Maya 1.5 Base

How to Set up Reflections and Refractions Maya 2.5 Complete

How to Share Texture Nodes Maya 2.5 Complete

How-to Set Up Depth of Field Maya 2.5 Complete
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  HOW TO MODEL A FLEXO WITH
MAYA

namtar@scsinet.es

by Lluís Llobera Trias - Quod/IDEP
Spain

Click to view larger version

Maya Complete
Animation

This is a tutorial to
create and make fully
operative, with Maya,
a flexo-type arm like
those used to hold
lights. You will work
with expressions,
driven keys, pivot
position, and
constraints. You will
also learn to add attributes and work with the Graph Editor.

The point of this exercise is to create a series of arms that
rotate properly together when the main arm of the flexo does.

Note: throughout the tutorial, you are told how to create a 5-arm flexo;
however, all the pictures contained in this document show a 10-arm
flexo. In fact, there's no arm limit as long as you follow the method
correctly.

   STEP ONE

In "extensible" arms
such as these, you get
the same element
repeated a number of
times. Therefore it is
very important that the
first arm created has
some kind of a solid
structure. You are
going to create a cylinder grouped twice with itself, positioning
the pivot for every node in a proper position.
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Create a NURBS cylinder and name it "c_i", for "inferior
constraint". Go to the Channel Box and set its Y scale
to 10, and its Z scale to 0.4.

●   

Enter "Insert" to edit the Pivot Point position, then go to
the Numerical Input Line, which is a white space just
above the Channel Box. Enter the values 0 -10 0.

●   

You should see that the pivot has moved at the bottom of the
cylinder. Enter "Insert" again to go back to object editing
mode.

Group the cylinder with itself, and name the new group "c_s",
for "superior constraint". Now follow the previous steps to
position its pivot point at the top of the cylinder (that's 0 10 0).

Group the node c_s with itself, and name the new group
"SUP_01". Now you can rotate the node SUP_01 45 degrees
in the Z axis. You have successfully created the first arm of
the flexo.

   STEP TWO

Enter
Edit->Duplicate->
Options and reset the
values.

Duplicate the node
SUP_01 and name its
copy INF_01. In the
Channel Box, set its Z
translation to 1.

Now you are going to create an expression to make this new
node rotate every time that the superior arm does. Check that
INF_01 is still selected, and go to Window->Expression
Editor. Name the new expression "inf_rotate", and enter in the
expressions area

INF_01.rz = 180 - SUP_01.rz ;

Click on "Create". From now on, every time that the SUP_01
rotates in the Z axis, the INF_01 will rotate also. Check it if
you want. After you have, set the Z rotation for the SUP_01 to
45 again -- the whole exercise will assume this as its value.

Since the arms of the flexo are alternated, you will now have
to move the pivot points of the c_i and c_s nodes of the
SUP_01 and INF_01 arms in an absolute Z translation of 0.5.
To achieve this, the easiest procedure is to select each of the
sub-nodes, click "Insert" and, in the Numeric Input Line,
enter

. . 0.5
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You will have to repeat this operation for each of the
sub-nodes.

   STEP THREE

Select SUP_01 and
INF_01 and then select
Edit-> Duplicate->
Options. Set the
number of copies to 4
and click on the
"Duplicate Input
Connections" box.

When you click on
"Duplicate", Maya will create four new superior cylinders,
called SUP_02 to SUP_05, and four inferior cylinders which
are named INF_02 to INF_05. Select in the Outliner the nodes
SUP_02 and INF_02, and set them to an X translate of 14
units. Pick the next two nodes, move them to 28, and so on.

Now look what happens when you rotate the SUP_01 : only
the inferior arms rotate with it. This is because only INF_01
had the expression applied, and therefore the superior arms
aren't aware of what is going on.

   STEP FOUR

Select the nodes
SUP_02 to SUP_05
and (in the
Animation menu)
select
Animate-> Set
Driven
Key-> Set-> Options.
The Set Driven Key
window will pop up (from now on, we will call it SDK). In the
"Driven" frame you'll see the four nodes you have just
selected.

In any orthographic window select the SUP_01 and, returning
to the SDK, click on "Load Driver" to place it in the "Driver"
frame.

Click on the "Rotate Z" next to the Driver frame (it'll get dark),
and select the four nodes in the Driver. Click on their "Rotate
Z". Now click on "Key" to set the first connection.

Select the SUP_01 node and set its Z rotation to 60 degrees.
After that, select the SUP_02 to SUP_05 nodes and rotate
them to 60 in Z as well. In the SDK window, set the second
connection by clicking on "Key". Close the SDK.
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Look what you have now: the superior arms only seem to
work properly when the Z rotation of SUP_01 is between 45
and 60 degrees. Let us fix this.

Select the nodes SUP_02 to SUP_05 and go to Window->
Animation Editors-> Graph Editor. Press the "f" key to
execute a "frame all"; a blue curve will appear in the right
window. Select it (all of it, including its beginning and end) and
enter :

Curves -> Pre Infinity -> Cycle with Offset

Curves -> Post Infinity -> Cycle with Offset

Close the Graph Editor. Now all the arms rotate correctly.

 STEP FIVE

Using the Outliner or
the Hypergraph, add
constraints from
certain nodes to the
other ones. This is the
formula to do it:

Select the node
c_i from
SUP_0x, then
the node c_s
from INF_0(x+1).

●   

Select
Constraints->
Point. You also
have to do it the
other way
around, i.e.:
select the node
c_i from INF_0x,
then the node
c_s from
SUP_0(x+1) and
select
Constraints->
Point.

●   

For example, the first step is to select c_i from SUP_01 and
c_s from INF_02 and constraint them. Then, pick the c_i from
INF_01 and the c_s from SUP_02 and constraint them too.
Continue until you have no arms left.
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   STEP SIX

You should now have
the flexo working
correctly. But having to
depend on the Z
rotation for SUP_01 is
time consuming, and
inefficient.

Now we will create a
new node with an attribute to get it to work.

Select all the nodes (Right Click and "select all" is the
easiest way) and group them.

●   

Name the group "FLEXO".●   

Enter "Insert" to edit its pivot point position.●   

Go to the Numeric Input Line and enter:●   

. 15 .

Select Display-> Objects Components-> Selection
Handles. From now on, you'll be able to select the whole
object by clicking on this handle.

Now select Modify-> Add Attribute. Name the new attribute
"Length", enter 0 for its minimum value, 100 for the
maximum, and 50 as default value.

Select the node SUP_01, and select Animate -> Set Driven
Key -> Set -> Options. Load the node FLEXO as the driver.
Select the attribute "Length" next to the Driver frame, and the
Z rotation from the Driven frame. Press Enter.

Set the "Length" Value to 0, and the Z rotation for SUP_01 to
0. Click on "Key". Now set "Length" to 100 and the Z rotation
for the SUP_01 to 90. "Key" it again.

Click to view larger version

CONCLUSION

Well then you have
just finished building
the flexo!

Now it's up to you to
add details, such as
the joints (which
should be constrained
to the nodes c_i from
the arms), etc.

Here's the final file for
you to download. You can open it with any version of Maya.

flexo.ma (~270k)
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Use of this file confirms your agreement to the Terms and Conditions
set out on the Terms and Conditions page.
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   HOW TO BUILD AN IRIS By Alan Harris

Play Movie [321 k]

Maya Complete
Animation

In this lesson, you will learn
how to build an iris and use
Set Driven Key to animate it
opening and closing.

To achieve this, you will
create a locator and add an
attribute called Shutter. This
attribute will range from 0 to
10. 10 equals the iris in closed the position.

   STEP ONE

Set the Grid Options to
default settings.

Create two Nurbs circles at
the origin -- one 10 units and
the other 5 units. Template
them to use as guides.

Create a closed CV
Curve as shown.

●   

Duplicate the curve
and translate in Y to
-0.2

●   

Select the top curve
and select Surfaces >
Planar.

●   

Select the top curve
and the bottom curve
and select Surfaces >
Loft.

●   

Delete the curves or
delete history on the
surfaces.

●   
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   STEP TWO

You will need to group these
surfaces twice to get two different
pivot points. One for creating the
subsequent shutters and the other
for the local rotation.

Select the two surfaces.●   

Select Edit > Group and
rename this node localPivot.

●   

Select the node localPivot,
then select Edit > Group
again and rename this node
centerPivot. This node should
be at the origin.

●   

You will now change the location of
the localPivot.

Select the localPivot node.●   

Press Insert on the keyboard
to modify the pivot point.

●   

In the top view, Move the pivot
to the corner of the shutter
piece as shown.

●   

Press Insert again when
finished.

●   

   STEP THREE

You will now be duplicating
surfaces to create the other
pieces.

Select the centerPivot
node.

●   

Select Edit >
Duplicate - Options
and set the following:

●   

Rotate Y to 30;
Translate Y to 0.1;
Number of Copies to
11
Press Duplicate.●   
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   STEP FOUR

You will be creating a Locator with an attribute called shutter to
control the opening and closing of the iris.

Select Create > Locator.●   

Select Modify > Add Attribute... and set the following:●   

Attribute name to shutter;
Minimum to 0;
Maximum to 10
Press OK.●   

   STEP FIVE

The Locator now needs a connection to the rotation attribute of
the local pivot. To achieve this connection, you will use Set
Driven Key .

Select all twelve of the localPivot nodes.●   

Select Animate > Set Driven Key > Set - Options.●   

With the localPivots selected, press Load Driven.●   

Highlight all the localPivots in the left column.●   

In the right column of the Driven section, highlight rotate
Y.

●   

You will now load the Locator as the Driver.

Select the Locator.●   

Press Load Driver.●   

Highlight the locator in the left column.●   

In the right column of the Driver section, highlight shutter●   

In this next step you will be setting the keys.

Press Key.
This will set a key for the shutter value of 0 when the iris
is fully open.

●   

In the Channel Box, set the shutter value to 10.●   

Select all the localPivot nodes.●   

Highlight the Rotate Y attribute name in the Channel Box.●   

Use the virtual slider with the MMB in the workspace by
click- dragging to the left until the iris is closed.

●   

Press Key.●   

Test the Set Driven Key by selecting the Locator and entering
different values or by using the virtual slider.
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   CONCLUSION

You should now have the
shutter attribute controlling
the animation of the iris.
Experiment with different
curve shapes and amount
of shutters. You can also
experiment with different
translate offsets when
duplicating the shutters.

Your use of this file confirms your agreement to the
Terms and Conditions set out in the Terms and Conditions page.
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  HOW TO PICK UP AN OBJECT by Robert Magee  

Play Movie [224 k]

Maya Complete
Animation

In this lesson, you will
learn how to make an
Inverse Kinematic arm
pick up an object and
place it on a table. This
will involve constraining
the IK handle to two
Locators then animating
the constraint weights to
switch the hand between locators.

The key to this lesson is that you will animate the object first
then constrain the arm to match that movement. This ensures
that the object's movement is exactly what you want before you
even have to consider the character picking it up.

 STEP ONE

Create a polygonal
cube. Scale it to create
a tabletop. In the front
view, place it on the
ground along the X axis.
Rename the cube's
transform node to table.

Create a NURBS
cylinder. Scale it so that
it is a little taller. Place it on the ground near the origin. This will
be the object that will get lifted up onto the table. Rename the
cylinder's transform node to glass.
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 STEP TWO

In the front view, place
three Joints to create a
simple arm that will pick
up the glass and place it
on the table.

Add an IK handle that
runs from the root joint
to the end joint of the
skeleton.

 STEP THREE

Create two Locators.
Place one to the left of
the glass and name it
glassLocator. This
locator will drive the arm
when it is picking up the
glass.

Place the second
locator up above the
glass and name it freeLocator. This locator will drive the arm
when it is not picking up anything.

 STEP FOUR

In the Hypergraph
window, parent the
glass node to the
glassLocator node. Now
any animation you apply
to the locator will also
affect the cylinder.

 STEP FIVE

Select the two locators
and then the IK handle.
Make sure that the IK
handle is selected last.

Select Constrain ->
Point to constrain the
handle to both locators
at once. It will constrain
to a point half way
between the two locators.
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If you Select and Move the freeLocator, you will see that the IK
handle updates so that it always places itself halfway between
the two locators. Both locators have been constrained using the
same weighting, so the IK handle is trying to point at both
constraints equally, The result is that the IK Handle is
positioned at an equal distance between the two locators.

 STEP SIX

Select the IK handle. In
the shapes section of
the Channel box, you
will find the
ikHandle1_pointConstraint1
shape node. It contains
two key attributes:

glassLocatorW0
which is the
weighting of the
glass locator; and

●   

freeLocatorW1
which is the
weighting of the
other locator.

●   

Set the glassLocatorW0 attribute to 0. Now the IK handle will
move to the freeLocator since it has the strongest weighting. If
you Select and Move the freeLocator, you will see that the IK
handle now follows this locator entirely, because you have told
it not to point at the glassLocator at all.

 STEP SEVEN

You will now animate the
glass so that it is
positioned exactly where
you need it.

Create a CV curve from
the glassLocator upward
to the top of the table.

This will be used as a
motion path for animating the movement of the glass. You
could also simply set keys on the glass, but using a motion path
offers another way to animate it.
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